FutureQuest, Inc. FutureQuest, Inc. FutureQuest, Inc.
Knowledgebase: PHP/MySQL
PHPML (PHP MultiLevel) and eselect
Posted on 19 September 2014 12:42 PM

FutureQuest provides MultiLevel Versions of PHP, which is known as PHPML.


The Default version of PHP is the most current stable version of PHP and you can determine what version of PHP your package is currently using from your CNC Server Info Page.

All new accounts are activated with the default version of PHP enabled.

This is also where you can change the default version of PHP for your account. 

Simply select which version of PHP you want to use with which service for your account and then click the Update button. 
(The Selection box will list the exact version of PHP, ie... 5.3.29 or 5.4.33 etc...)

For more advanced users you can manage your PHP MultiLevel Version from Command Line via SSH.

Log into your account via SSH and the following commands are available:

#To show the help output
$ eselect phpml

#To show your current PHP CGI/CLI versions
$ eselect phpml show all
$ eselect phpml show cli
$ eselect phpml show cgi

# To set your PHP CLI versions (e.g. for 5.6)
$ eselect phpml set cli 5.6
$ eselect phpml set cli 3 (number derived from $ eselect phpml list cli)

# To set both PHP CGI and CLI at same time
$ eselect phpml set all 5.6


ZendGuard support is provided for PHP 5.3.x - 5.4.x
ZendGuard has not yet been released for PHP 5.5.x - 5.6.x

Note: FutureQuest does NOT recommend the use of PHP 5.2.17, it's end of life was in Jan 2011, however if you have a script that requires PHP 5.2.17 we do provide that support, however it must be requested by contacting the Service Desk from a Valid Contact address for your account, Service@FutureQuest.net
ZendOptimizer support is only available with PHP 5.2.x